You are here: Foswiki>Tasks Web>Item13452 (26 Sep 2016, GeorgeClark)Edit Attach

Item13452: Extensions web enhancements for compatibility, encoding, etc.

pencil
Priority: Enhancement
Current State: Confirmed
Released In: n/a
Target Release:
Applies To: Web Site
Component:
Branches:
Reported By: GeorgeClark
Waiting For:
Last Change By: GeorgeClark
Copied from Item13446 which was hijacked for these issues:

This task is the tip of an iceberg. We have a number of issues lurking that need resolution
  • Re-encoding of Topic text and text attachments during copy in Foswiki::Configure::Package
  • Extensions release process, and dealing with encoding during upload
  • Config.spec issues with encoding.

The extension installation process has had this issue forever, but it's only obvious now that iso-8859-1 isn't our default. On Foswiki 1.1.x, any extension could run into these issues if the target System didn't use {Site}{CharSet} = iso-8859-1.

I expect we need a developers discussion on how to handle the CharSet used in our git repository, and how to release in a portable format. I'll propose some ideas here:
  • Default encoding of extensions should be iso-8859-1. unless they cannot be used on Foswiki 1.1
    • This keeps good compatibility with Foswiki 1.0 / 1.1
  • New non-backwards-compatible extensions should default to utf-8
  • Package form and installer should flag the character set used in the distribution.
  • 1.2 Package installer needs to detect / default the distribution encoding, and re-encode into the {Store}{Encoding} during installation
  • pseudo_install is another can of worms. Can't symlink incompatible encodings.
  • pseudo-install should be a feature of Foswiki::Configure::Package. Linking when requested, and only for compatible encoding.
    • This would solve other issues related to incomplete installation of config.spec, Plugin module name, etc.

-- GeorgeClark - 06 Jun 2015

OhMyGod! This isn't an iceberg, but Pandora's box. frown, sad smile It is hard to believe what has evolved from simple questions on IRC about the DateTimePlugin. I tried somewhat classify what plugins should be tested for the "1.2 compatibily", but this is really an mess.

For example:
  • In the github we have 570 repositories (Extension, Plugins, Addons, Contribs - etc..), plus 45 Contribs/Addons from the "distro".
  • when the wizard consults the foswiki's web with the query:
    http://foswiki.org/Extensions/JsonReport?contenttype=application/json;skin=text;release=Foswiki-1.2.0_Beta_1;version=v1.1.999_002;pluginsapi=2.3
    it gets returned (thanks God) only 310, so the list is somewhat filtered on the server side.
  • However, the filtering works strangely, because it sure isn't based on the received (release,version,plugins) parameters, because for example it still offers to install the ZonePlugin what is ages in the core and sure not needed for the 1.2. frown, sad smile

We badly need somewhat :
  • classify, what plugins are in the real use
    • I asked gac410 about some usage stats, be noting such exists.
    • Maybe something could be extracted from the log-files - e.g. what plugins are downloaded in the last 7 years and how many times... wink
    • also, i could extract from the git log what plugins are got updates from 2008, (not counting the global updates, as replacing TWIKIWEB to SYSTEMWEB and like)
    • but this is simply doesn't helps at all. cry
  • update for the each actively used plugin the required informations about its compatibility. Doing this for each plugin, is an terrible and hard work and TBH, many plugins are useless.
  • offer for download really only highly polished extensions - as our marketing texts states wink

Please, consider:
  • Extensions what doesn't installs cleanly and without any errors from the configure's Extension installer (or its command-line equivalent e.g. tools/extension_installer) should not be offered.
  • Foswiki shouldn't be as the "goods" from chineese e-shops, where the quantity replaces the quality.
  • offering for download problematic extensions hurts Foswiki reputation (Repeat this with myself several times.)
  • experienced users, who are able manage to work some rarely used and problematic extensions, they sure will be able to manage manually download them from the github or FO.
  • We really badly needs classify what extensions are in the active and common use. (e.g. it is used not only by the extension author).
  • unmaintained extensions should be not offered for download, or only after checking some checkbox, in the Wizzard interface - "only at your own risk".
  • also, the IRC-guest shown another problem: he states: the DateTimePlugin didn't works, because it didn't works nor in the foswiki.org. We need:
    • install to foswiki.org all our flagship and really highly polished extensions,
    • and clearly mark in the FO's Extension web - the list of installed plugins. Maybe, enough add to the top of the Extensions an TWISTY section what ajax-includes the InstalledPlugins topic. The user should know the extension's installed-status.

Easy to implement Idea:
  • in the 1.2 - the bootstrap process should generate one unique UUID for each Foswiki installation (e.g. the bootstrap should hardcode this UUID into some source code, or at least as an variable in the LocalSite.cfg).
  • and this UUID should be sent with the extensions wizard with each "study" and/or "download" request. It is completely anonymous but allows to us gather some more-real plugin usage/install stats.
  • the above probably isn't too hard to implement - for CDot probably 20 minute smile
  • A bit more hard is implementing an new section to the configure what asks the users to allow SHARE with the FO
    • the list of all currently installed extensions
    • and some other (but fully anonymous) usage info
    • and sent this info as an JSON string to FO - for example once a month when if and when the user runs the configure.

And finally, the most important question: please have anyone any usable idea how to continue (or better said - how to start) with the extension compatibility testing?

Also, I hate Pandora. frown, sad smile Uff...

-- JozefMojzis - 07 Jun 2015

George, I somewhat disagree with the Default encoding of extensions should be iso-8859-1. It is a step backward and in the future we will cope with the non-uniformity charset-problem again. frown, sad smile We need (IMHO) convert all current (non-ascii) extensions to utf8. Now and forever, and offer to download only good extensions. wink

-- JozefMojzis - 07 Jun 2015

I think MultiLingualPlugin is better suited for translations than DateTimePlugin as it lets you add translations as part of the wikiapp.

-- MichaelDaum - 07 Jun 2015

There are 363 extensions using PackageForm, which has a Compatibility field. Unfortunately this field is used very badly. Ultimately we depend on extension authors to test compatibility, but there's no reason to make it hard to record!

I propose the following:

  1. We change the Extensions.Compatibility field to a radio group, similar to that in Tasks web where we select compatibility options.
  2. We work through the known extensions and fix the compatibility field. I think it's reasonable to assume 1.1.x compatibility for any extension not explicitly labelled otherwise.

Looking into the future, one idea would be to automatically extract the compatibility from the DEPENDENCIES of an uploaded extension. this would require all extensions to explicitly state the Foswiki version they are tested on (this could be forced in a checkin trigger)

Compatibility of an extension can depend on many variables, including:
  • Which Foswiki version you are running n the server,
  • Which OS you are running on server and client,
  • Which other extensions you have installed,
  • Which versions of CPAN modules you have installed,
  • Which browsers are going to be used, and how they are configured,
The compatibility field of an extension cannot be taken as the final word on this subject; it is merely a set of guidelines that the extension author has used to indicate what has been tested, and indicate where there may be problems.

Searched: form.name='PackageForm'
AcronymDefinitionsPlugin Tested on Foswiki 1.1.4 / Apache / Linux / Chromium.
ActionTrackerPlugin Foswiki 1.1
Does NOT work on Foswiki 1.0 any longer.
AliasPlugin  
AntiWikiSpamPlugin  
ApprovalPlugin Foswiki >=1.0
AttachContentPlugin Foswiki 1.0
AttachLinkPlugin  
AttachmentFilterPlugin  
AttachmentListPlugin  
AttachmentUrlShortcutPlugin  
AutoRedirectPlugin  
AutoSavePlugin  
AutoSubPlugin  
AutoTemplatePlugin  
AutoViewTemplatePlugin  
AvatarPlugin  
BarcodePlugin Foswiki-1.0.0
BatchUploadPlugin Foswiki >= 1.1 only
BeautifierPlugin Foswiki 1.0.9
Firefox/Win 3.5.9
Safari/Win 3.2.3
BehaviourContrib Foswiki 1.0.0
BibliographyPlugin Foswiki >= 1.0
BibtexPlugin  
BigBlueButtonPlugin  
BioKbPlugin Tested in Fedora 10, Foswiki 1.07
BlackListPlugin Foswiki 1.0.4
BlogAddOn  
BlogPlugin  
BookmakerPlugin  
BreadCrumbsPlugin  
BridgePlugin  
BrowserBoosterPlugin  
BrowserDetectPlugin  
BugsContrib  
BugzillaLinkPlugin  
BuildContrib  
CKEditorPlugin  
CacheContrib  
CalDAVPlugin  
CalendarPlugin  
CaptchaPlugin  
CasLoginContrib  
CharsetConverterContrib  
ChartPlugin  
ChecklistPlugin 2.0.0, 1.1.9, 1.1.8, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0
ChecklistTablePlugin Foswiki-1.0.0
ClamAVScanPlugin Foswiki 1.0, 1.1 and 2.x Not tested on Windows.
ClassificationPlugin  
CmisPlugin  
CommentPlugin  
CompareRevisionsAddOn  
ConfigurePlugin Foswiki 2.0.2. Do not install this update on Foswiki 1.x, 2.0.0, or 2.0.1.
ContributorsPlugin foswiki 1.0
ControlWikiWordPlugin  
CopyContrib  
CounterPlugin  
CpanContrib  
CssPlugin  
DBCacheContrib  
DBCachePlugin  
DBConnectorPlugin Not maintained, does not work out of the box. Try SqlPlugin instead.
DBIPlugin  
DBIQueryPlugin  
DBIStoreContrib Foswiki 1.1.9 and later
DataFlowDiaPlugin  
DatabaseContrib  
DatabasePlugin  
DateManipPlugin  
DateTimePlugin Foswiki 1.2.0 or earlier
DbiContrib  
DebianRepositoryPlugin  
DebugLogPlugin  
DelayMacroPlugin Any Foswiki version
DiffPlugin  
DigestPlugin  
DirectedGraphPlugin 2.0.0, 1.1.9, 1.1.8, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.10, 1.0.9, 1.0.8, 1.0.7, 1.0.6, 1.0.5, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0
DirectedGraphWebMapPlugin  
DisqusPlugin  
DistributedServersPlugin  
DocumentViewerPlugin 2.0.0
DojoToolkitContrib  
DownloadZipPlugin  
DoxygenPlugin  
DpSyntaxHighlighterPlugin 1.1.9
DrawIOPlugin  
DrupalUsersContrib foswiki 1.0
EasyMacroPlugin  
EasyTimelinePlugin Foswiki: 1.0, 1.1
OS: Linux, Windows, Mac OSX
EditChapterPlugin  
EditRowPlugin Foswiki 2.0.2. Do not install this version on Foswiki 1.x, 2.0.0, or 2.0.1.
EditSyntaxPlugin  
EditTablePlugin Foswiki 1.1
Do not install on Foswiki 1.0.x
EidoGoPlugin  
EmptyPlugin Foswiki 1.0.0
EncryptPlugin  
ExcelImportExportPlugin  
ExitPlugin Does not work with any released Foswiki version. Should not have been uploaded in its current state
ExpandTopicContentPlugin Foswiki 1.0, 1.1 and 2.0
ExplicitNumberingPlugin Tested with Foswiki 1.0
ExportCookiePlugin Foswiki 0.9 and up
ExportPlugin  
ExtendedWebListPlugin  
ExtensionTemplate  
ExtensionsRepositoryContrib  
ExternalLinkPlugin 2.0.0, 1.1.9, 1.1.8, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.10, 1.0.9, 1.0.8, 1.0.7, 1.0.6, 1.0.5, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0
FSBrowserPlugin Tested on Foswiki 1.1.4 / Apache / Linux / Chromium.
FamFamFamContrib  
FamilyTreePlugin  
FarscrollContrib  
FastCGIEngineContrib  
FeedPlugin  
FieldHistoryPlugin  
FilesysVirtualPlugin  
FilterPlugin  
FindElsewherePlugin  
FirebugLitePlugin  
FlexFormPlugin  
FlexPaperPlugin  
FlexWebListPlugin  
FlotChartPlugin Foswiki 1.0
FlowchartPlugin Foswiki-1.0.0
FootNotePlugin  
ForEachPlugin  
FormFieldListPlugin 20 Jun 2009 (v2.1)%0d%0a
FormListPlugin  
FormPlugin  
FormQueryPlugin  
FortunePlugin All Foswiki Versions
FoswikiApplicationsContrib  
FoswikiOrgPlugin Specific for Foswiki.org
FoswikirefsPlugin Foswiki 1.1
FreeMarkerPlugin  
FreeMindPlugin 1.0..
FugueIconsContrib Installation using unzip is recommended. The Web based extension installer will most likely time out due to the very large number of files copied into the installation.
FullCalendarPlugin Does not work with Foswiki 1.1.9 due to JQuery changes. (curCSS has been removed).
GaugePlugin Foswiki >= 1.0
GenPDFAddOn Foswiki 1.x, on Linux or Windows. Requires htmldoc.
GenPDFPrincePlugin  
GenPDFWeasyPlugin  
GenPDFWebkitPlugin  
GeoIPPlugin  
GeoPlugin  
GetAWebPlugin Foswiki 1.0. Not working on Foswiki 1.1 (Tested on 1.1.8) Uses private store API methods missing in 1.1.
GlobalReplacePlugin Tested on Foswiki 1.0
GluePlugin ALERT! WARNING: this plugin is not maintained by the original author anymore.
GnuPlotPlugin  
GoUptoTocPlugin  
GoogleAnalyticsPlugin  
GoogleMapsPlugin  
GraphvizPlugin  
GridLayoutPlugin  
HTTPDUserAdminContrib 1.0
HarvestPlugin  
HeadlinesPlugin Foswiki 1.0.0
HighchartsPlugin  
HijaxPlugin  
HistoryPlugin  
HolidaylistPlugin  
HomePagePlugin  
HoneyPotPlugin  
HostnamePlugin Foswiki >=1.0
HttpHeaderPlugin  
HttpsRedirectPlugin  
HyphenationPlugin  
HyphenatorContrib  
ICalPlugin  
IfDefinedPlugin  
ImageGalleryPlugin  
ImagePlugin  
ImmediateNotifyPlugin  
ImportExportPlugin  
InfiniteScrollContrib  
InterwikiPlugin  
IpPlugin Runs on Foswiki trunk; port of a version running on TWiki trunk as of Oct-2012
IpToUserMappingPlugin foswiki 1.1+
JEditableContrib  
JHotDrawPlugin  
JQAjaxFormContrib  
JQAutoColorContrib  
JQAutoLogoutContrib  
JQCodeInputContrib  
JQDataTablesPlugin  
JQFullCalendarPlugin  
JQGridPlugin  
JQMomentContrib  
JQPackeryContrib  
JQPhotoSwipeContrib  
JQPrettyPhotoContrib  
JQRCodeContrib  
JQSelect2Contrib  
JQSerialPagerContrib  
JQTablePlugin Should work with all versions of Foswiki.
JQTweetContrib  
JQTwistyContrib  
JQueryCompatibilityModePlugin  
JQueryLibPlugin Tested with 1.0.5 on Windows and Linux.
JQueryMenuSkin  
JQueryPlugin Currently not compatible with Foswiki 1.1. A patch will be released to restore compatibility.
JSCalendarContrib  
JSPopupPlugin Compatibility issue have been reported with JQuery on Foswiki 1.1.4
JSTreeContrib  
JSUnitContrib Deprecated: the source code "upstream" is no longer maintained.
JasmineBddContrib  
JoomlaUsersContrib  
JsonRpcContrib  
JsonSQLPlugin Foswiki 2.x
KinoSearchContrib Foswiki 1.0.x; 1.1.x (NOTE: Setting the stores search algorithm to Kino in 1.1.x does not currently work. See Foswiki:Tasks.Item10543 for more details)
KinoSearchPlugin Foswiki 1.0.x
LatexModePlugin Foswiki 1.0.x
LazyLoadPlugin  
LdapContrib  
LdapGuiPlugin Tested on:
Foswiki-1.1.8, Plugin API version 2.2
OpenLDAP-2.4.28
Ubuntu precise 12.04.2 LTS
Mozilla Firefox 19.0.2
Apache/2.2.22

LdapNgPlugin  
LightboxPlugin Foswiki 1.0.x
LikePlugin  
LimitedSessionsPlugin  
LinkOptionsPlugin  
LinkedInPlugin foswiki 1.1
ListyPlugin  
LocalCityTimePlugin  
LocalTimePlugin  
LogDispatchContrib  
LoginNameAliasesPlugin 1.0
LoremIpsumPlugin  
MailInContrib Should work with all versions of Foswiki. Tested with IMAP and POP3 mail servers, though it can be tricky to configure them sometimes.
MailerContrib  
MarkdownPlugin  
MathModePlugin  
MediaElementPlugin  
MediaPlugin  
MediaWikiTablePlugin  
MediaWikiToFoswikiContrib  
MeetingBingoPlugin  
MenuListPlugin 1.0
MermaidPlugin  
MetaCommentPlugin  
MetaDataPlugin Foswiki >= 1.1.0
MetaWorkflowPlugin Foswiki >= 1.0
MicroformatsPlugin  
MimeIconPlugin  
MirrorWebPlugin Foswiki 1.0+
ModPerlEngineContrib  
ModifyLoginPlugin  
MoreFormfieldsContrib Please upgrade to MoreFormfieldsPlugin
MoreFormfieldsPlugin  
MostPopularPlugin  
MoveableTypeSkin  
MsOfficeAttachmentsAsHTMLPlugin Tested on Foswiki 1.0.0 and TWiki 4.2.3
MultiLingualPlugin  
MultiSaveContrib  
MultiSearchPlugin  
MultiTopicSavePlugin  
NTLMEmailAuthContrib Foswiki 1.1
NatEditPlugin  
NatSkin  
NatSkinPlugin  
NativeSearchContrib Foswiki 1.0
NewUserPlugin  
NotificationPlugin  
NuSkin  
NumberPlugin  
OEmbedPlugin  
ObjectPlugin  
OpenIDLoginContrib  
OpenSourceProjectInAWebContrib  
OrphansPlugin  
PageOptimizerPlugin  
PasswdUserContrib Developed for Foswiki 1.0.x - not tested on 1.1, but it's pretty simple.....
PatchFoswikiContrib Applies to any Foswiki 1.1.x or 2.0 version. Does not include any patches.
PatchItem12225Contrib Applies to any Foswiki 1.1.x version before Foswiki 1.1.6. This should be installed prior to installing any extensions released with Foswiki 1.1.6
PatchItem12285Contrib Foswiki 1.1.0 - Foswiki 1.1.6
PatchItem12391Contrib All Foswiki 1.1.x releases
PatternSkin Foswiki 2.0. Do not install on Foswiki version 1.x.
PdfPlugin  
PerforcePlugin  
PerlPlugin Foswiki 1.0+
PermLinkPlugin Should run on any OS.
PersonalInfoAddOn  
PhotoGalleryPlugin Foswiki 2.1.3 or later, modern HTML5 browsers, Linux server, some exotic Perl modules
PhpBB3UsersContrib  
PhyloWidgetPlugin  
PiwikPlugin  
PixabayPlugin  
PlainFileStoreContrib 2.0.0
PlantUMLPlugin  
PreferencesPlugin  
PrefsCachePlugin Foswiki 1.1.9 and later
PubLinkFixupPlugin Foswiki 2.0
PublishPlugin  
QMPlugin  
QRCodePlugin  
QuickMenuSkin  
RCSStoreContrib 2.0.0
RackPlannerPlugin  
RandomTopicPlugin  
RatingContrib Tested with VotePlugin on 1.0.5., WARNING: RatingContrib is incompatible with latest JQueryPlugin which comes with a rating formfield of its own.
RedDotPlugin  
RedirectPlugin  
RedmineQueryPlugin v2.1.0
RegexCacheSearchPlugin  
RemoveTrashPlugin Tested on Foswiki 1.1.4 / Apache / Linux, Chromium.
RenderFormPlugin  
RenderListPlugin  
RenderPlugin  
RenderTableDataPlugin Tested on Windows and Linux. Any Foswiki version.
RevCommentPlugin 2.0.0, 1.1.9
RevisionLinkPlugin Foswiki 1.0.0+
RtfContrib  
SafeWikiPlugin  
SamlLoginContrib  
SearchEngineKinoSearchAddOn  
SectionListPlugin  
SecureDownloadPlugin  
SecurityHeadersPlugin  
SendEmailPlugin  
SetFormValuesPlugin  
SetSkinByCookiePlugin  
SetTopicValuesPlugin  
SetVariablePlugin  
ShibLdapContrib  
SignaturePlugin  
SimpleFTPPlugin Tested with Foswiki 1.1.6.
SkillsPlugin Foswiki >1.0
TWiki >4.2
SlickSitemapContrib Foswiki 1.0.0
SlideShowPlugin  
SmartEditContrib  
SmartWordBreakPlugin Browsers: IE6, IE7, IE8, FF3, Opera 10
Foswiki: Should work will all versions from 1.0.4 onwards. Tested with 1.0.7 and trunk (1.1)
SmiliesPlugin  
SmsTwoStepAuthContrib  
SnazzyRoundedCornersContrib  
SoapClientPlugin  
SoapPlugin  
SocialBookmarkingAddOn Foswiki >= 1.0
SocialSharePlugin  
SoftSkin  
SolrPlugin  
SpacedWikiWordPlugin  
SpreadSheetPlugin  
SpreadsheetReaderPlugin  
SqlPlugin  
StringifierContrib  
SubscribePlugin 2.0
SyntaxHighlightingPlugin Foswiki >=1.0
TWikiCompatibilityPlugin  
TablePlugin  
TableTmplPlugin  
TablesContrib 1.1.9
TagCloudPlugin  
TagMePlugin Tested on Foswiki 1.0.5. The original author is highly unlikely to want to support this plugin.
TagsPlugin foswiki
TalkContrib  
TaskManagementContrib Tested on Foswiki 1.1.4.
ThumbnailPlugin Foswiki-1.0.0 (TWiki version available at twiki.org)
TimeCalcPlugin  
TimeSincePlugin  
TimeTablePlugin  
TimelinePlugin  
TinyMCEPlugin  
TipsContrib Foswiki 2.0.2. Do not install this update on Foswiki 1.x, 2.0.0, or 2.0.1.
TocPlugin Should work with any Foswiki
ToolTipPlugin Tested with Firefox 3 and IE 6. IE 6 has issues drawing the balloon tips.
TopSecretPlugin  
TopicClassificationAddOn  
TopicCountPlugin  
TopicCreatePlugin 2.0.0, 1.1.9, 1.1.8, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.10, 1.0.9, 1.0.8, 1.0.7, 1.0.6, 1.0.5, 1.0.4, 1.0.2, 1.0.1, 1.0.0
TopicDataHelperPlugin  
TopicInteractionPlugin  
TopicListPlugin  
TopicLockPlugin  
TopicNameValidationPlugin  
TopicSpecificNavigationPlugin  
TopicTitlePlugin  
TopicTranslationsPlugin  
TopicUserMappingContrib Foswiki 2.0. Do not install on Foswiki version 1.x.
TopicVotePlugin  
TrashPlugin  
TreeBrowserPlugin  
TreePlugin 2.0.0, 1.1.9
TweetOnSavePlugin Foswiki 1.0.x
TwistyPlugin  
TwitterPlugin  
TypographyPlugin  
UnitTestContrib  
UnixUsersContrib  
UpdateAttachmentsPlugin All releases of Foswiki.
UpdateInfoPlugin  
UpdatesPlugin  
UploadPlugin ALERT! WARNING: this plugin is deprecated and been superseded by TopicInteractionPlugin.
UrlEventHandlerPlugin  
UserInfoPlugin  
ValidateUrlsPlugin  
VarCachePlugin Foswiki 1.0.0
VirtualHostingContrib  
VotePlugin  
WaveDromPlugin  
WebAutoIncPlugin  
WebCreatorPlugin  
WebDAVContrib  
WebDAVLinkPlugin  
WebFontsContrib  
WebLinkPlugin  
WebPermissionsPlugin Foswiki 1.0. The "More Actions" menu does not work on Foswiki 1.1
WidgetsSkin  
WikiAppInstallerPlugin  
WikiDrawPlugin foswiki
WikiWorkbenchContrib  
WordPressPlugin  
WorkflowPlugin  
WysiwygPlugin  
X509UserPlugin This extension does not work on Foswiki 1.1.x See Tasks.X509UserPlugin. In addition, the "Group management" API additions to the TopicUserMapper are not implemented.
XMLStoreContrib  
XSendFileContrib  
XmlRpcContrib  
XslFoContrib  
YouShallHaveNoOtherLoginsBeforeMePlugin  
ZonePlugin Foswiki 1.0 only. Functions provided by Foswiki core in 1.1
Number of topics: 415
-- CrawfordCurrie - 09 Jun 2015

ItemTemplate edit

Summary Extensions web enhancements for compatibility, encoding, etc.
ReportedBy GeorgeClark
Codebase trunk
SVN Range
AppliesTo Web Site
Component
Priority Enhancement
CurrentState Confirmed
WaitingFor
Checkins
ReleasedIn n/a
CheckinsOnBranches
trunkCheckins
masterCheckins
ItemBranchCheckins
Release02x01Checkins
Release02x00Checkins
Release01x01Checkins
Topic revision: r2 - 26 Sep 2016, GeorgeClark
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy